More from: パソコン

EXCEL自体も不調なのかも・・・・

先の記事のEXCELのトラブルの元となったファイルを送り返したが、送った先では解決していないとのこと。
同じファイルを他のPCのEXCEL2007で開くと問題無いとのことだし、私のところのEXCEL2003でも大丈夫なので、問題はPC側にもあるような感じがしてきた。
当面そのファイルは問題無く扱えるPCで扱ってもらうことにした(解決になってないなぁ、、、)。

←クリックしてくれると嬉しいです。

EXCELで「セルの書式が多すぎるため、書式を追加できません」が出る

職場で「エクセルのファイルで書式を変えようとすると、今まで見たことがないエラーメッセージが出て変更できない。調べて欲しい。」と言われたので、そのファイルを送って貰って調べてみた。
ファイルサイズが約1MByteと少々大きめのファイルだったが、特に大きすぎるというわけでも無い。
早速開いてセルの書式設定をしようとするが、最初の内はどのセルでやってもエラーにならない。
手当たり次第に試しても埒が明かないので、数式が設定されているセルを中心に試したところ、特定のセルで現象が発生した。
エラーメッセージは「セルの書式が多すぎるため、書式が追加できません。」というもの。
早速Googleで探してみると約3000件弱がヒット。その内の幾つかのページを見ると原因と対策が出ていたので、それを試したところ取り合えず解決した。
マイクロソフトのサポートページ「Excel でエラー メッセージ “表示形式を追加できません” が表示される」によるとセルに設定した書式の組み合わせが4000を超えた場合に発生するらしい。
同ページに出ていた対策で解決するのかもしれないが、なにせ他人が業務で使用しているファイルなので、勝手にセルの書式を変更(単純化等)は出来ない。
しかも問題のセルの書式変更をしようとしても上記エラーが出るので変更そのものが出来ない。
で、ここを参考にツールバーから「書式」→「スタイル」を選んで、使っていなさそうなスタイルの削除を試してみた。
そうしたところ、プルダウンメニューで出てくるスタイル名の中に文字化けしたものがあったので、それを削除したところ問題が解決してしまった。
どうも問題のファイルの中に壊れたスタイルがあったらしく、それを削除したところ正常に戻ったものと思われる。
ファイルサイズも約30KByte程減少したので設定してあったスタイルがなんらかの原因で壊れていたらしい。

できるExcel 2010 Windows 7/Vista/XP対応
小舘由典 できるシリーズ編集部

できるExcel 2010 Windows 7/Vista/XP対応
できるWord 2010 Windows 7/Vista/XP対応 できるPowerPoint 2010 Windows 7/Vista/XP対応 (できるシリーズ) できるExcel関数編 2010/2007/2003/2002対応 できるWindows 7 (できるシリーズ) できるWindows 7 活用編 (できるシリーズ)
by G-Tools

Excel 2010 完全制覇パーフェクト
鈴木 光勇
4798121584

←クリックしてくれると嬉しいです。

やっぱりつながる・・・・・・

Windows7機を再起動したら問題無く接続できるようになった。
やはりメモリ(非ページ)が不足しているようだが、なにがそんなにメモリを消費しているのだろう?
タスクマネージャで見てもメモリを大量に消費しているプロセスが見当たらないので、終了しても非ページプールを抱えたまま離さない行儀の悪いプログラムがいるのかなぁ?
もしそれがD510MOのドライバだったら最悪だなぁ、、、、、

←クリックしてくれると嬉しいです。

Windows7とXpでのファイル共有

自宅のPCのOSはWindow7HP,Windows7Pro,WindowsXpHome,WindowsXpProが混在している。
※いや、他にもWindows系統のOSはあるけど、普段使っているのはこれくらい。他にLinuxも常用している。
それらのPC間でファイルの共有を設定しているが、数日前まではWindows7HPのPCへWindowsXPのPCから接続できなくなっていた。
WEB等で調べてもみたが、なかなか解決できず放置していたが、ある日突然解決していた。
それまでXp(Home,Pro共)側からはWindows7Proには接続できて、Windows7HPには接続できなかった(Windows7同士はOK)。
反対にWindows7HPからXpHomeには問題無く接続できていたので、プロトコルやファイアウォールの問題では無さそう。
見たところWindows7ProとWindows7HPのPCで設定に違いがあるようには見えなかったが、何故かWindows7HPにだけアクセスできなくなっていた。
WEB等で情報を探すと「パスワード保護」を外せばOKだの、セキュリティ上問題のありそうなことばかり。
これは外したくなかったのでかけたまま、暗号化のビット数も128bitにしてある。
とりあえずWindows7HP側からXpには接続できていたので、ファイルのやり取りは可能だったため困ることは無かったが、ある日Windows7HP側を再起動した後に試してみるとXp側から接続できるようになっていた。
あれ?でも今試してみるとXpPro側から接続できなくなっているなぁ、、、、なんでだろ?一昨日はできたのに???

気になるのはエラーメッセージの最後が
「このコマンドを処理するのに必要な記憶域をサーバーで確保できません。」
となっていること。本当にメモリが足りないのか?(Windows7HPのPCのメモリは僅か2GByte)
Windows7HP側のイベントログを見てみると、非ページプールの割り当ての制限に達したため、非ページプールを割り当てることが出来ません云々というログが出ている。
どうもそのせいで接続できないらしいが、

によると64bit版Windows7では非ページプールの最大値は物理メモリの75%(このPCでは1.5GByte)にもなるので、これが不足するとは思えない。
でもまぁメモリ不足ならとりあえず再起動で直りそうだが、根本的な解決にはならないぁ、、、

追記:後日解決したので、その方法を「Xpと7でのファイル共有(SMBの問題が解決)」に書いておきました。

←クリックしてくれると嬉しいです。

ATOM D510のエンコード能力の続き

D510MOで組んだPCで動画ファイルを再生するとコマ落ちや音飛びが発生するのは、画面サイズが大きいファイルの一部でのみ発生するらしいことが判ってきた(あくまで私の環境においてのみだが)。
というのは画面サイズの小さい(横640~720pixel程度)のファイルを再生しながら、再生画面のサイズを大きくしても問題無く再生されたから。
もし表示処理が追い付かないのがコマ落ちの原因であれば、再生画面のサイズを大きくしても同様な問題が発生すると思われる。
ところが、そのようなことが発生していないということは、コマ落ちの原因はデコード処理能力の不足では無いかと推測される。
他にもいろいろ試してみないことにはなんとも言えないが、現状で考えられることは上の通り。
エンコード方式やビットレートによっても影響を受けると思うので、今度はそちらに焦点を当てて検証してみるか。

←クリックしてくれると嬉しいです。

←クリックしてくれると嬉しいです。

ATOM D510のエンコード能力

IntelのD510MOで組んだPCで画面サイズの大きい(幅1280p程度)動画を再生すると、コマ落ちや音飛びがあることは以前書いた。
幅が720p程度の動画では現象の発生が見られないので、考えられる原因は
1.HDDからのデータ読み込みが遅い。
2.読み込んだデータから画像情報に戻す(デコード)処理が追いつかない。
3.デコードされた画像(この場合は動画)データの表示が追いつかない。
等が考えられる。

この内「1.」に関しては、データを保存しているHDDのベンチマークを取ってみた。
このHDDはUSB接続の外付けケースに入れてあり、他のPCからも参照できるように共有をかけてある。

USB接続HDDのベンチ結果

USB接続HDDのベンチ結果

この結果からするとシーケンシャルリードで30MByte/s以上出ているので、ビットレートから考えても読み込みが遅いとは思えない。
実際にPhenomIIx4 905eを載せたPCからネットワーク越しにこのHDDにアクセスして同じ動画ファイルを再生しても問題無く再生される(コマ落ちも音飛びも無い)ことからHDDからのデータ読み込みが原因では無いと言える。

「2.」及び「3.」については明確に測定できる環境が無いのでなんとも検証しにくいが、以前HDDベンチで測定した結果を見ると描画系のスコアが非常に低いので、主な原因は「3.」だという感じがする。
でもそれだと音飛びが発生するのが判らない、、、、、やはりデコードも追いついていないのかもしれない。
そういえば浮動小数点演算のベンチ結果がCeleron1.2GHzにも劣っていたから、やはりデコードも遅いのかもしれない。
OSがWindowsXpだった頃に測定した時は描画系もそこそこ速かった(というか遅くなかった)から、一度OSをXpに戻して試してみるとなにか判るかもしれない。

←クリックしてくれると嬉しいです。

USBフラッシュメモリの速度を試した

昨日CPUクーラーを買いに行った際、USBフラッシュメモリの特売品(8G品:通常価格2,980円→1,360円)があったので衝動買いをしてしまった(またかよ)。
見てみると「Windows Readyboost」対応と書いてあった(前回購入したものもそうだったけど)ので、また試してみた。

前回と同じくD510MOで組んだPC上でCrystalDiskMark2.2を使用してベンチマークを取った。
前回FAT32でもNTFSでも結果が殆ど同じだったので、今回はFAT32のみで測定。

測定結果

測定結果

前回の結果と比較するとシーケンシャルと512Kのランダムはリード/ライト共20%以上数値が上がっているが、4Kのランダムはリード/ライトどちらも殆ど変化が見られない。
4KのランダムリードのみがHDDより速いが(約10倍)、こんなんでReadyBoostを利用したほうが本当にパフォーマンスが上がるのだろうか?

←クリックしてくれると嬉しいです。

CPUクーラーを交換してみた

2/2の記事「CPUクーラー」でCPUファンの音が気になるので交換したいと書いたが、昨日交換用のCPUクーラーを購入してきた。

購入したのはThermaltakeの「桜扇(ふぁん) CLP0537-A ISGC-100」

静音化の為に購入したCPUクーラー

静音化の為に購入したCPUクーラー(Thermaltake CLP0537-A ISGC-100)


ショップの店員さん曰く「とっても静かです!」だったので、少々迷っていたが思い切って購入した。
#本当は「サイズ SHURIKEN(手裏剣) Rev B SCSK-1100」を買いに行ったんだけど、品切れとのことだった。
帰宅後取りつけようとしたところ、向きによってはヒートパイプがCPUソケット周辺のコンデンサに干渉してしまうので、取り付ける向きは実質1方向しか選べなかった。
なんとか取りつけることは出来たが、良く見ると今度はヒートパイプがメモリに当たっていて、メモリモジュールが歪んでしまっている。
あまりにも危なっかしいので、泣く泣くメモリを1枚外してしまった。
外した後で上から見るとヒートパイプがものの見事にメモリスロットを横断している。
この手のCPUクーラーはCPUソケット周りに余裕が無いと取り付けられないことを改めて実感してしまった。
ちなみにマザーはPC CHIPSのA15GというMicroATXマザー。このマザーに今回のCPUクーラーは「使えない事は無い。」と言うことが判明した。

なんとか取りつけたCPUクーラーだが、動作音ははっきり判るくらい小さくなった。今度はケースファンかなぁ?、、、、と泥沼にはまりつつあるのか?(爆)

←クリックしてくれると嬉しいです。

WORD2007が起動しないPC

2009/11/24の記事「WORD 2007を起動できない」に書いたPCは結局OS(Windows VISTA Business)ごとリカバリしてしまった。
なので、起動できない原因も対策も不明なまま。
ただ、このPCと同じ機種で同時期に購入したものの内、既に2台ほどでHDD故障が発生してメーカー保証でHDDを交換している。
あまり関係無いとは思うけど、、、、、、

←クリックしてくれると嬉しいです。